Jump to content


1fx. Mod goes gold!


  • Please log in to reply
646 replies to this topic

#641 ShinChan

ShinChan

    Advanced Member

  • Members
  • PipPipPipPip
  • 184 posts
  • LocationNetherlands

Posted 12 October 2019 - 04:39 PM

It's been a while since there has been a post regarding 1fx gold.

We've noticed more regular crashes on windows (Usually it just stops responding and crashes, nothing is displayed in the logs or anything).
So we're looking into moving linux (+ it's cheaper to use linux then windows), but I've noticed that for the gold version the sof2ded doesn't work.

Or atleast, I'm getting "./Start Server.sh: 5: ./Start server.sh: ./sof2ded not found".
When trying just run ./sof2ded in sof2 root, I'm getting "bash: ./sof2ded: No such file or directory".

I've tried both the one provided in the 1fx mod linux zip and the one from here, but both didn't work.

When downloading the v1.00 version, it doesn't show this behaviour.

Permissions have been set 744 and as an executable.

I'm trying to make it run on Debian 10.
Posted Image

#642 Janno

Janno

    henkie loves me

  • Moderators
  • 614 posts
  • LocationTallinn, Estonia

Posted 13 October 2019 - 08:17 AM

noop puni, gold works for me mens

Anyhow, try downloading 32bit libs. I suppose that’s the issue. You can google for Debian multiarch

Some extra info here: https://askubuntu.co...the-file-exists

Ps - l2google hhh
HENKHODOREHODOREHODORE

#643 ShinChan

ShinChan

    Advanced Member

  • Members
  • PipPipPipPip
  • 184 posts
  • LocationNetherlands

Posted 13 October 2019 - 12:55 PM

View PostJanno, on 13 October 2019 - 08:17 AM, said:

noop puni, gold works for me mens

Anyhow, try downloading 32bit libs. I suppose that’s the issue. You can google for Debian multiarch

Some extra info here: https://askubuntu.co...the-file-exists

Ps - l2google hhh

Forgot to mentino that i already tried the multiarch from Debian, and libc6.
However i vaguely remembered something regarding libcxa.so from the last time i tried it, and started searching on that, finding an old topic from back in 2002.
http://modsonline.co...-top-38772.html

which mainly mentioned about getting the libcxa.so.1 file from the 1.02 linux distro, (which i found on boe's site), and add em in my /usr/lib.
Posted Image

#644 Janno

Janno

    henkie loves me

  • Moderators
  • 614 posts
  • LocationTallinn, Estonia

Posted 13 October 2019 - 05:02 PM

View PostShinChan, on 13 October 2019 - 12:55 PM, said:

Forgot to mentino that i already tried the multiarch from Debian, and libc6.
However i vaguely remembered something regarding libcxa.so from the last time i tried it, and started searching on that, finding an old topic from back in 2002.
http://modsonline.co...-top-38772.html

which mainly mentioned about getting the libcxa.so.1 file from the 1.02 linux distro, (which i found on boe's site), and add em in my /usr/lib.
...and did that wrok?
HENKHODOREHODOREHODORE

#645 ShinChan

ShinChan

    Advanced Member

  • Members
  • PipPipPipPip
  • 184 posts
  • LocationNetherlands

Posted 13 October 2019 - 08:46 PM

Thought i said it in the post, but that was the thing that fixed it.

Doing:
"dpkg --add-architecture i386"
"apt-get update"
"apt-get install libc6:i386"
"wget http://boeboe.uk.to/...02/libcxa.so.1"
"mv libcxa.so.s1 /usr/lib"

Made it work for me.

For future reference when anybody else has the same issue.

Edited by ShinChan, 16 October 2019 - 03:22 PM.

Posted Image

#646 ShinChan

ShinChan

    Advanced Member

  • Members
  • PipPipPipPip
  • 184 posts
  • LocationNetherlands

Posted 22 October 2019 - 08:48 PM

Does the fps limiter takes care of pmove_msec?
Posted Image

#647 BoeMan

BoeMan

    Developer

  • Administrators
  • 4018 posts
  • LocationFryslân

Posted 23 October 2019 - 08:29 PM

Hi, excellent question. The way the FPS limiter (g_noHighFPS) works in 1fx. Mod is actually by taking pmove_msec in account, so yes, it probably will.
Kind regards,

BoeMan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users