Jump to content


Bots on SoF2 MP TEST


  • Please log in to reply
6 replies to this topic

#1 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 4 posts

Posted 03 September 2019 - 10:56 PM

Hello,

So I set up a server on the demo version of the game and everything is working fine except for three things:

1) The bots I added to the server are only using knives, is there a way I can get them to use guns?

2) I also don't seem to be able to change the gamemode from caserun, it says it will change upon restart but im not able to restart the server without closing the console and opening it again.

3) When a game does finish, the screen sits on the "server is changing maps please wait" thingy forever and doesn't load anything.

Any help for these matters would be greatly appreciated.

Thank you

Edited by pINKER, 03 September 2019 - 11:08 PM.


#2 BoeMan

BoeMan

    Developer

  • Administrators
  • 4016 posts
  • LocationFryslân

Posted 04 September 2019 - 04:30 PM

Hi Pinker,

I haven't really tested out bots on demo yet. Did you alter any of the bot files yet?

As for the restart, the way to normally "restart" is by restarting the map. You can do this through one of the following commands:
  • map mp_shop
  • mapcycle
  • map_restart 0

As for point three, that probably means your mapcycle is not functioning correctly. What does your console say? Can you post the output here?

Thanks!
Kind regards,

BoeMan

#3 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 4 posts

Posted 05 September 2019 - 10:28 AM

Hi BoeMan,

The only edits I made to the bot files was creating new ones with the code copy pasted, allowing me to change their names and chat messages, I also edited the little text document that allows me to add the bots to the server. I left their weapon settings on default.

Thank you for the restart commands, I will be sure to try them out

Here is a link to the output I get when the map tries to change: https://pastebin.com/RFqrgCyh

#4 BoeMan

BoeMan

    Developer

  • Administrators
  • 4016 posts
  • LocationFryslân

Posted 06 September 2019 - 05:55 AM

Hi Pinker,

Looking at the output is a little embarrassing for me. Apparently I shipped a faulty entity file with the MP TEST version of 1fx. Mod.

Could you try downloading the file below and put this file in /1fx/maps/dm? Cycling through maps should work fine then.

Thanks!

Attached Files


Kind regards,

BoeMan

#5 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 4 posts

Posted 06 September 2019 - 06:46 AM

Hi BoeMan,

Thank you for the file, I am able to switch the server to deathmatch now, but that brings about a new problem.

The rcon addbot command now isn't recognized by the server.

Also before I switched to deathmatch, the bots were still stuck using knives in caserun.

https://imgur.com/a/B6eHQll


EDIT: Disregard this post, somehow I managed to join a different server when i was changing the gamemode (???) ill let you know what happens when it switches itself to dm

Edited by pINKER, 06 September 2019 - 06:50 AM.


#6 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 4 posts

Posted 06 September 2019 - 07:02 AM

Hi BoeMan,

Sorry about my previous post im not sure what happened there.

The file works flawlessly and I can add bots while in dm, thank you so much for that again.

The bots are able to shoot with the pistols they spawn with, though now weapons aren't spawning on the map and the bots quickly run out of ammo. I tried setting g_pickupsDisabled to 1 in the Config file so they would spawn with a loadout, but that causes the bots to just use the knives again.

Also after a while, the bots freeze in place forever

Edited by pINKER, 06 September 2019 - 07:32 AM.


#7 BoeMan

BoeMan

    Developer

  • Administrators
  • 4016 posts
  • LocationFryslân

Posted 07 September 2019 - 06:03 AM

Hi Pinker,

From what I gather from the screenshot you accidentally switched maps with e.g. /map mp_shop instead of /rcon map mp_shop. Doing the command without RCON lets you host and enter your own (local) server. That server isn't using 1fx. Mod, hence you cannot do addbot or any of the other 1fx. Mod commands. 1fx. Mod is supported as dedicated server only.

As for your weapon problem, open up the bot file and tweak the weapon weights accordingly. I created a default set for you, here:

BotWeaponWeights
{
	WP_NONE				0
	WP_KNIFE			1
	WP_M1911A1_PISTOL		10
	WP_US_SOCOM_PISTOL		11
	WP_M590_SHOTGUN			14
	WP_MICRO_UZI_SUBMACHINEGUN	16
	WP_M3A1_SUBMACHINEGUN		15
	WP_USAS_12_SHOTGUN		17
	WP_M4_ASSAULT_RIFLE		20
	WP_AK74_ASSAULT_RIFLE		22
	WP_MSG90A1_SNIPER_RIFLE		13
	WP_M60_MACHINEGUN		21
	WP_MM1_GRENADE_LAUNCHER		24
	WP_RPG7_LAUNCHER		25
	WP_M84_GRENADE			3
	WP_SMOHG92_GRENADE		5
	WP_ANM14_GRENADE		4
	WP_M15_GRENADE			2
}

It's not perfect, but if you are running INF with semi-default settings this will cause most bots to spawn with an AK47 and some with a M590. Tweak accordingly.

As for the bots freezing in the server, this is a known issue that I haven't bothered to pick up yet. The bot code in 1fx. Mod is almost fully vanilla right now, causing some bugs here and there. This is still on the to do list for later. I also don't know how the Demo version handles bots engine-wise. There has never been bot support in MP TEST before 1fx. Mod.
Kind regards,

BoeMan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users