Jump to content


1fx mod with patched SOF2 MP TEST


  • Please log in to reply
9 replies to this topic

#1 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 9 posts

Posted 13 December 2019 - 01:19 AM

Hi,

A few months ago I made some servers that ended up working perfectly (Thanks Boeman!) and now that I have some more spare time im starting on a new project.

On Sof2 MP TEST im looking to make a server that runs through different maps using 1fx mod.

I began working on it this morning and have run into an issue, I use a patched version of the game to be able to run different maps. This involves replacing the exe file of the game with a different one.

I downloaded a new copy of the 1fx server files for sof2 mp test, however I replaced the 1fx version of the exe with the patched one and naturally that gave me an error ( https://pastebin.com/Juw1NYKX )

Is there a way I could get the patched version of the game to work with the 1fx server files? I will provide a download to the patched version if required.

Thanks in advance

-Pinker

#2 BoeMan

BoeMan

    Developer

  • Administrators
  • 4023 posts
  • LocationFryslân

Posted 13 December 2019 - 11:56 PM

Hi there Pinker,

Sure, you can post the executable here and I will patch it for you. But wouldn't it be easier to just keep separate directories? One for your server and one for your client. That is also the recommended way to run 1fx. Mod.

If you do want a shared install, post the executable here. I'll get back at you with the fixed executable in a couple of days.
Kind regards,

BoeMan

#3 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 9 posts

Posted 14 December 2019 - 02:12 AM

Hi BoeMan,

I am using different directories for my server and my client, however the demo version of Sof2 doesn't like other maps and only works with this patched exe, thats why im hoping to be able to use it with 1fx

Here is a download to the patched version, if you could make it work with 1fx that would be absolutely amazing.

http://www.mediafire.../mohaa.exe/file

Thank you

#4 BoeMan

BoeMan

    Developer

  • Administrators
  • 4023 posts
  • LocationFryslân

Posted 16 December 2019 - 07:09 PM

Here you go: http://boeboe.uk.to/pub/mohaa.exe

I haven't tested it, please verify if it works this way.
Kind regards,

BoeMan

#5 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 9 posts

Posted 17 December 2019 - 01:31 AM

Thank you so much Boeman it works pretty much flawlessly!

Just one thing though, on some maps the bots dont seem to spawn anywhere

Edited by pINKER, 17 December 2019 - 01:39 AM.


#6 BoeMan

BoeMan

    Developer

  • Administrators
  • 4023 posts
  • LocationFryslân

Posted 17 December 2019 - 08:19 PM

Could you download Bsp2Ent from the Downloads section and extract the entity of some of those maps? Or, if you can't find it, give me an example of such a map?

Demo is the only version that respects the "nobots" and "nohumans" entity keys on spawns, it's possible some of the maps actually contain nobots spawns. This is just one of the few things still present in Demo but not in the full game from vanilla Quake III.

/*QUAKED info_player_deathmatch (1 0 1) (-16 -16 -24) (16 16 32) initial
potential spawning position for deathmatch games.
The first time a player enters the game, they will be at an 'initial' spot.
Targets will be fired when someone spawns in on them.
"nobots" will prevent bots from using this spot.
"nohumans" will prevent non-bots from using this spot.
*/

Kind regards,

BoeMan

#7 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 9 posts

Posted 18 December 2019 - 01:02 AM

Hi Boeman,

I used pakscape to grab the bsp from the pk3 file, then used bsp2ent to convert it to a .ent file, I hope thats okay.

I first noticed the issue with mp_raven so ill attach that here, I can go through the maps and attach all of the ones that aren't working with bots later today if you'd like.

http://www.mediafire...1/mp_raven/file

Thank you again for helping out, I really appreciate it.

#8 BoeMan

BoeMan

    Developer

  • Administrators
  • 4023 posts
  • LocationFryslân

Posted 18 December 2019 - 06:48 PM

I don't see anything unusual, it should work fine.

What happens when you add a bot? Can you spectate the bot, or does it go in the spectator team? Could you attach the console log?
Kind regards,

BoeMan

#9 pINKER

pINKER

    Newcomer

  • Members
  • Pip
  • 9 posts

Posted 18 December 2019 - 11:35 PM

When it happened I would go into spectator mode and not be able to spectate the bot despite it being on a team.

However for whatever reason when I turned the server on this morning to test it again it appears to be working fine.

If it happens again i'll attach the logs for you, sorry for wasting your time earlier.

#10 BoeMan

BoeMan

    Developer

  • Administrators
  • 4023 posts
  • LocationFryslân

Posted 19 December 2019 - 01:05 PM

Not a problem, glad you got it working. Bots on MP TEST have never been tested, before 1fx. Mod there was no possibility to add bots to a MP TEST server.

If it happens again I'll take a look.
Kind regards,

BoeMan




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users