Jump to content

Issue Information

Issue Confirmations

  • Yes (0)No (0)

Cant make map elim

Posted by empy on 21 February 2016 - 02:40 PM

Hello, I cant get singleplayers maps into elim. It will change to dm. !gt elim or setting it in the config also won't work.

Also cant change to inf, ctf and tdm. Weird thing is that I can change to h&s and h&z.

Post the arena file contents please.

Stupid me.

But weird thing is hk4 elim.
This is the arena file:
map "hk4"
longname "hk4"
type "dm tdm elim ctf inf"

And this is the map in the mc:
command "altmap pra5"
scorelimit 0
timelimit 10
g_roundtimelimit 4
g_gametype h&s
g_motd "32^mN^;e^rx^Lt ^LM^+a^7p is hk4! ^3(^7Stab ^3/ ^7 SL5 ^3/ ^7TL 15^3)"
g_speed 300
g_gravity 800
g_customWeaponFile "weaponfiles/h&s.wpn"
hideseek_Nades "1111"
hideSeek_Weapons "000"
hideseek_extra "000001"
hideSeek_roundstartdelay 20
command "map hk4"
scorelimit 5
timelimit 10
g_roundtimelimit 4
g_gametype elim
g_motd "33^mN^;e^rx^Lt ^LM^+a^7p is kam5! ^3(^7Timelimit 10^3)"
availableWeapons 200000002000000000000
g_customWeaponFile "weaponfiles/ak_stab.wpn"

I think it has to do with that i use 2 Mc files. It happens in the second mc file, when the dm(which should be elim) ends it goes to the first map of the second mc, so it loops.

Can you PM me both files? I haven't tried running a mapcycle with two files yet.


I can't see where you put the elim map on the last map, but in theory your method should work fine, except switching back to mapcycle 1. You have 22 maps in your second mapcycle file (to map22), if you force the CVAR back to mapcycle 1, it will continue on map23. map24 has the entry to switch to mapcycle 2.

If you don't want this issue, keep a continuous count. Start with map0 in mapcycle 1, continue with map25 in mapcycle 2 after setting the CVAR. That should work correctly and won't have the switching back issues that I mentioned.

And another thing, your map7 in mapcycle 2 (which is an elim map) starts correctly with the "map7" header, the map after it doesn't (map8 missing). That will result in going back to map0. Always test these configurations thoroughly.

Thanks! the missing map8 explains that it loops. The elim I mean is g_motd "33^mN^;e^rx^Lt ^LM^+a^7p is kam5! ^3(^7Timelimit 10^3)" in mapcycle2.txt. I'll continue with map25 in mapcycle2 and report back if it works.

The loop is fixed thanks! But the map still becomes dm instead of elim.

I removed the g_gametype from the config file, the hk4 works now but now another elim doesnt work.

I had a similar issue on my homeserver a while back, for some reason some restarts it wouldn't probably switch to the desired gametype. It'd just switch to DM.

It took me forever to find out it was a duplicate CVAR change causing the issue. I had set g_gametype in my Config.cfg to a gametype. I also set the value in my mapcycle file.

If the value in the Config.cfg is different than the value it was when the server shut down, the new CVAR  value will become latched. The second g_gametype value won't take effect and the first gametype would be loaded. Hence the gametype would only properly start sometimes, and not always.

Your issue might be similar. Remember that h&s/h&z gametypes are really just INF with some other settings applied. The latched CVAR value is always h&s or h&z so the map properly loads the same gametype the next map. Try changing from another gametype, like ctf, to see if you have the same issue. If that happens, I might be able to properly reproduce the issue.

0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users