Jump to content


iamoblvn's Content

There have been 4 items by iamoblvn (Search limited from 16-July 18)


Sort by                Order  

#24810 1fx. Mod goes gold!

Posted by iamoblvn on 17 December 2017 - 06:55 PM in 1fx. Mod

View PostBoeMan, on 17 December 2017 - 06:35 PM, said:

Hi all, an update from my end.



I just looked at the issue, weirdly it was an issue on my end which makes me wonder why all servers seemed to work except yours.. I suspect it was broken for a long time now but since no-one uses them anymore, it was never noticed.

I already pushed the update, version 1.20, and your client should start downloading it once you connect to the HoP server. Since the downloader is broken in 1.10, you might need to connect twice. That's a guess though.

Changes in 1.20:
- Added ui_1fxAdditionsVerbose CVAR. When set to 1, it prints additional information regarding the 1fx. HTTP Downloader to the console. Default is 0.
- Added the running Operating System to the default user agent.
- Fixed error while downloading multiple .pk3 files.

The new ui_1fxAdditionsVerbose CVAR will come in handy if it ever stops working like this again.

The full source commit, for those interested, is here.

New Client Additions automatically mean updated base files, so those will build overnight (9th nightly of 0.82).



That sounds like a client problem. What server is this in? I'll check it out myself.



Like Punisher noticed, we currently don't have any way to disable the thermals and the night goggles. The question remains, do you really want to? In SoF2 there's no way to disable them from the outfitting. We never included this since it might be confusing for players (you select goggles but get armor).



Hi! Care to share the solution in case someone else runs into the exact same issue? I exclusively test on Debian.



Can give me the output of the directory listing (ls -l) in your main SoF2 directory and in ~/.sof2 ? Are you sure the owner is set correctly?

Thanks!

Oh obviously my bad, i forgot to change the permissions in ~/.sof2 ...
Thanks for the hint, it's working fine now!

As for my first issue not being able to start the server with a normal user: also wrong permissions, once fixed server starts perfectly.

Thank you!



#24808 1fx. Mod goes gold!

Posted by iamoblvn on 17 December 2017 - 03:45 PM in 1fx. Mod

View PostShinChan, on 17 December 2017 - 01:41 PM, said:

make sure sof2mp.cfg has writing permissions, and isn't set to "Read only".

sof2mp.cfg has not been created yet, atleast I don't see it in the directory.
I have confirmed I have writing permissions to everything.

Thanks



#24806 1fx. Mod goes gold!

Posted by iamoblvn on 17 December 2017 - 11:26 AM in 1fx. Mod

View Postiamoblvn, on 16 December 2017 - 12:58 PM, said:

Hi there!

I'm having troubles starting the server as normal user.
Starts fine with sudo.

I'm on Ubuntu 17.04 x86_64.

------- Game Initialization -------
Mod: 1fx. Mod 0.81
Date: Jul 7 2017
Port: SoF2 - v1.03
----- Server Shutdown -----
Resolving master.sof2.ravensoft.com
master.sof2.ravensoft.com resolved to 104.40.23.123:20110
Sending heartbeat to master.sof2.ravensoft.com
Resolving master.1fxmod.org
master.1fxmod.org resolved to 178.62.14.201:20110
Sending heartbeat to master.1fxmod.org
Sending heartbeat to master.sof2.ravensoft.com
Sending heartbeat to master.1fxmod.org
==== ShutdownGame ====
^1Error: BotLibShutdown: bot library used before being setup
User defined signal 1

Thanks!

Solved the problem but ran into another problem: Couldn't write sof2mp.cfg.
Is this a permissions problem?

------- BotLib Initialization -------
^1Error: counldn't load weapons.c
^1Fatal: couldn't load the weapon config
3 bots parsed
^3Bot route data not found
Gametype initialized: dm
Loading Default chat Sounds
Number of Chat sound files to Parse: 1
Parsing chat file: 1fx_SoundPack.vchat
Loaded 110 sounds.
Checking userdata integrity...
Succesfully finished checking userdata integrity.
-----------------------------------
Couldn't write sof2mp.cfg.
Hitch warning: 1199 msec frame time
Resolving master.sof2.ravensoft.com
master.sof2.ravensoft.com resolved to 104.40.23.123:20110
Sending heartbeat to master.sof2.ravensoft.com
Resolving master.1fxmod.org
master.1fxmod.org resolved to 178.62.14.201:20110
Sending heartbeat to master.1fxmod.org



#24803 1fx. Mod goes gold!

Posted by iamoblvn on 16 December 2017 - 12:58 PM in 1fx. Mod

Hi there!

I'm having troubles starting the server as normal user.
Starts fine with sudo.

I'm on Ubuntu 17.04 x86_64.

------- Game Initialization -------
Mod: 1fx. Mod 0.81
Date: Jul  7 2017
Port: SoF2 - v1.03
----- Server Shutdown -----
Resolving master.sof2.ravensoft.com
master.sof2.ravensoft.com resolved to 104.40.23.123:20110
Sending heartbeat to master.sof2.ravensoft.com
Resolving master.1fxmod.org
master.1fxmod.org resolved to 178.62.14.201:20110
Sending heartbeat to master.1fxmod.org
Sending heartbeat to master.sof2.ravensoft.com
Sending heartbeat to master.1fxmod.org
==== ShutdownGame ====
^1Error: BotLibShutdown: bot library used before being setup
User defined signal 1

Thanks!